A - Takahashi san 2 题解
A - Takahashi san 2
原题链接
Time Limit: 2 sec / Memory Limit: 1024 MB
Score : 100100 points
Problem Statement
KEYENCE has a culture of addressing everyone with the suffix "-san," regardless of roles, age, or positions.
You are given a string S consisting of lowercase English letters.
If S ends with san
, print Yes
; otherwise, print No
.
Constraints
- S is a string of length between 44 and 3030, inclusive, consisting of lowercase English letters.
Input
The input is given from Standard Input in the following format:
S
Output
If S ends with san
, print Yes
; otherwise, print No
.
Sample Input 1
takahashisan
Sample Output 1
Yes
The string S = takahashisan
ends with san
, so print Yes
.
Sample Input 2
aokikun
Sample Output 2
No
The string S = aokikun
does not end with san
, so print No
.
简单 判断最后字符串三个字母是否san,以及是否长度是否大于三即可。
最简单的方法是逐个比较
len = strlen(str);
if (len > 2) {
if (str[len - 3] == 's' && str[len - 2] == 'a' && str[len - 1] == 'n') {
printf("yes\n");
}
else {
printf("no\n");
}
完整代码
´´´c
#include <stdio.h>
#include <string.h>
int main() {
char str[100];
int len;
scanf("%s", str);
len = strlen(str);
if (len > 2) {
if (str[len - 3] =='s' && str[len - 2] == 'a' && str[len - 1] == 'n') {
printf("yes/n");
}
else {
printf("no/n");
}
}
else {
printf("no/n");
}
return 0;
}
´´´