当前位置: 首页 > news >正文

A - Takahashi san 2 题解

 

A - Takahashi san 2

原题链接


Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 100100 points

Problem Statement

KEYENCE has a culture of addressing everyone with the suffix "-san," regardless of roles, age, or positions.

You are given a string S consisting of lowercase English letters.
If S ends with san, print Yes; otherwise, print No.

Constraints

  • S is a string of length between 44 and 3030, inclusive, consisting of lowercase English letters.

Input

The input is given from Standard Input in the following format:

S

Output

If S ends with san, print Yes; otherwise, print No.


Sample Input 1

 

takahashisan

Sample Output 1

 

Yes

The string S = takahashisan ends with san, so print Yes.


Sample Input 2

 

aokikun

Sample Output 2

 

No

The string S = aokikun does not end with san, so print No.


简单 判断最后字符串三个字母是否san,以及是否长度是否大于三即可。

最简单的方法是逐个比较

len = strlen(str);

    if (len > 2) {
        if (str[len - 3] == 's' && str[len - 2] == 'a' && str[len - 1] == 'n') {
            printf("yes\n");
        } 

       else {

   printf("no\n");

}

    
 

 

完整代码

 ´´´c
#include <stdio.h>
#include <string.h>

int main() {
    char str[100];
    int len;

    scanf("%s", str);

    len = strlen(str);

if (len > 2) {
        if (str[len - 3] =='s' && str[len - 2] == 'a' && str[len - 1] == 'n') {
            printf("yes/n");
        } 

       else {
            printf("no/n");
        }

}
else {
            printf("no/n");
        }

    return 0;
}

´´´
 

 

 

 

 

 


http://www.mrgr.cn/news/43578.html

相关文章:

  • 第二百六十九节 JPA教程 - JPA查询OrderBy两个属性示例
  • InnoDB 事务模型
  • 一刷代码随想录总结:
  • 如何向文科生解释什么是计算机的缓存
  • centos7安装配置nginx
  • 双指针:滑动窗口
  • [单master节点k8s部署]29.Istio流量管理(五)
  • golang gorm
  • 八大排序--01冒泡排序
  • 基于keras的停车场车位识别
  • GoogleNet原理与实战
  • 内存缓存和硬盘缓存
  • 如何实现事件流操作
  • Mysql数据库约束
  • 【信息系统项目管理师考题预测】整合管理
  • 如何在 SQL 中创建一个新的数据库?
  • 【Codeforces】CF 2019C
  • AtCoder Beginner Contest 374 E题 Sensor Optimization Dilemma 2(二分,贪心)
  • Qt教程(002):Qt项目创建于框架介绍
  • 保险丝基础知识